Auto recognize ide from ProjectVersion

TwineCompile - Cut C++Builder compile times by up to 50x!
Post Reply
tzvif
Posts: 2
Joined: Tue Feb 01, 2022 5:05 am

Auto recognize ide from ProjectVersion

Post by tzvif »

Hi
I'm using jtmake to compile multiple versions of Embarcadero projects, such as RAD Studio XE4, Tokyo(10.2) and I recently started using RAD Studio version 11.2.
when I'm creating/changing a project using RAD Studio 11.2 it automatically changes the ProjectVersion to 19.5, but then when I run from the command-line the following command: jtmake "MyProject" I get an error:
Unknown project version "19.5".
if I manually edit the cbproj and change the ProjectVersion to 19.4 it works perfectly.
I know that the suggested solution is to explicitly specify the -ide flag while calling jtmake, but since I have multiple tools & procedures that use jtmake for different versions of the IDEs, it means that I'll have to change all of them to identify the correct -ide flag for each version.
Is there any way to make TwineCompile recognize projects with version 19.5 without having to add an extra flag?
I tried with TwineCompile from Get-It(version 5.4.2), and also with the latest trial version (version 5.5.1) and the issue persists.
Thanks in advance.
jomitech
Site Admin
Posts: 2159
Joined: Wed Oct 08, 2008 12:23 am

Re: Auto recognize ide from ProjectVersion

Post by jomitech »

Please download and extract this updated jtmake into the TwineCompile Program Files directory - it should resolve this issue.

https://jomitech.com/downloads/jtmake.zip
Jon
tzvif
Posts: 2
Joined: Tue Feb 01, 2022 5:05 am

Re: Auto recognize ide from ProjectVersion

Post by tzvif »

Thank you very much, this is indeed solve the problem.
Are you going to release this fix in the next version? do you have an estimation when this we be released via GetIt?
Thank you
Post Reply