Rad Studio 10 Seattle

TKrauss
Posts: 90
Joined: Thu Jul 21, 2011 8:22 am

Rad Studio 10 Seattle

Post by TKrauss » Fri Sep 11, 2015 3:02 am

Hi there,

The new Rad Studio 10 is released with 32bit CLANG.
ETA for the new TwineComile?

Will it be 4.3 or 5.0 (and need to rebuy)?

jomitech
Site Admin
Posts: 1964
Joined: Wed Oct 08, 2008 12:23 am

Re: Rad Studio 10 Seattle

Post by jomitech » Mon Sep 28, 2015 8:50 am

We're looking into the possibility of releasing a TwineCompile version for C++Builder 10. Unfortunately we do not have any dates at this time.
Jon

Promentum
Posts: 3
Joined: Mon Oct 12, 2015 7:49 pm

Re: Rad Studio 10 Seattle

Post by Promentum » Tue Oct 13, 2015 1:48 am

Hi Jon,
Do you have an update on Twine Compiler for C++ Builder 10?
I have bought 4 copies and it is soooo slow to build I can't bear to use them or roll them out to the team!

Promentum
Posts: 3
Joined: Mon Oct 12, 2015 7:49 pm

Re: Rad Studio 10 Seattle

Post by Promentum » Tue Oct 13, 2015 4:50 am

One extra point, C++ 10 Seattle also permits the use of the 'Classic Borland compiler' so it should be a failry trivial job to chnage Twine compiler to work under 10 with the 'Classic' compiler, surely this would be the same environment as XE8?
Thanks in advance, Max

jomitech
Site Admin
Posts: 1964
Joined: Wed Oct 08, 2008 12:23 am

Re: Rad Studio 10 Seattle

Post by jomitech » Tue Oct 20, 2015 8:44 am

We're working on the new version with Seattle support. Should be available in a few weeks.
Jon

Promentum
Posts: 3
Joined: Mon Oct 12, 2015 7:49 pm

Re: Rad Studio 10 Seattle

Post by Promentum » Mon Oct 26, 2015 10:48 am

Thanks!

Twine Compiler is such a great product we really miss it.

TKrauss
Posts: 90
Joined: Thu Jul 21, 2011 8:22 am

Re: Rad Studio 10 Seattle

Post by TKrauss » Thu Oct 29, 2015 4:06 am

I installed the new version on my Windows 10 and got an error:
At compilation the IDE crashes because a library isn't registered!
Which library?

jomitech
Site Admin
Posts: 1964
Joined: Wed Oct 08, 2008 12:23 am

Re: Rad Studio 10 Seattle

Post by jomitech » Thu Oct 29, 2015 3:57 pm

Can you provide the exact error that you receive? Is it just an error in the console output?
Jon

TKrauss
Posts: 90
Joined: Thu Jul 21, 2011 8:22 am

Re: Rad Studio 10 Seattle

Post by TKrauss » Fri Oct 30, 2015 1:54 am

The error in console when using jtmake is that there is an exception: a library isn't registered!

The IDE crashes without an exception when trying to compile a project.

jomitech
Site Admin
Posts: 1964
Joined: Wed Oct 08, 2008 12:23 am

Re: Rad Studio 10 Seattle

Post by jomitech » Fri Oct 30, 2015 8:51 am

Please try the following steps:

1. Copy JTBuildInterface10Seattle.dll from the TwineCompile Program Files directory into the IDE bin directory

2. Open a command prompt with administrative rights, cd to the IDE bin directory and run:

C:\Windows\Microsoft.NET\Framework\v2.0.50727\RegAsm JTBuildInterface10Seattle.dll /tlb:JTBuildInterface10Seattle.tlb

3. Delete JTBuildInterface10Seattle.dll from the IDE bin directory.

4. Open an Explorer window in C:\Windows\Assembly and drag JTBuildInterface10Seattle.dll from the TwineCompile Program Files directory into it.

5. Restart the IDE/jtmake and try again.
Jon

Post Reply