RAD Studio 10.4.2 - TwineCompile 5.2.2 doesn't work

TwineCompile - Cut C++Builder compile times by up to 50x!
Post Reply
virusman
Posts: 3
Joined: Fri Aug 16, 2019 6:52 pm

RAD Studio 10.4.2 - TwineCompile 5.2.2 doesn't work

Post by virusman » Sun Feb 28, 2021 11:14 pm

I just upgraded to C++ Builder 10.4.2, installed TwineCompile 5.2.2, and TwineCompile fails at any compilation attempt with this error:

Code: Select all

[TwineCompile Fatal] Exception thrown while building. (Interface not supported)
Attachments
TwineCompileError.png
(24.65 KiB) Not downloaded yet

jomitech
Site Admin
Posts: 2041
Joined: Wed Oct 08, 2008 12:23 am

Re: RAD Studio 10.4.2 - TwineCompile 5.2.2 doesn't work

Post by jomitech » Mon Mar 01, 2021 9:24 am

Yes, this is correct. Due to binary incompatibilities in the new 10.4.2 release, TwineCompile 5.2.2 does not work with it. You need to download the latest 5.2.3 release via the GetIt package manager in the IDE.
Jon

omtom
Posts: 2
Joined: Tue Mar 02, 2021 10:12 am

Re: RAD Studio 10.4.2 - TwineCompile 5.2.2 doesn't work

Post by omtom » Tue Mar 02, 2021 10:16 am

When will version 5.2.3 be available via GetIt-Manager?
I have a professional subscription.
Version 5.2.2 is shown to me under Sydney 10.4.1.
Under Sydney 10.4.2 I don't see any TwineCompile at all.

Can TwineCompile 5.2.3 also be downloaded from your website and when will it be possible?

Thanks for your answer.
omtom

jomitech
Site Admin
Posts: 2041
Joined: Wed Oct 08, 2008 12:23 am

Re: RAD Studio 10.4.2 - TwineCompile 5.2.2 doesn't work

Post by jomitech » Tue Mar 02, 2021 10:21 am

That is weird. 5.2.3 should be appearing in GetIt for you. It was available for 10.4.2 the day after the release announcement.

Can you send a message to Embarcadero to ask why you're not seeing it? Other people have been able to download it with no issues.

We'll be putting it up for download on our site within a day or so.
Jon

omtom
Posts: 2
Joined: Tue Mar 02, 2021 10:12 am

Re: RAD Studio 10.4.2 - TwineCompile 5.2.2 doesn't work

Post by omtom » Wed Mar 03, 2021 3:19 am

Thanks for your answer.
Today, for whatever reason, I was offered version 5.2.3 for download.

So my problem has been resolved.

Post Reply