[C++ Builder 10.3.3] Color issues

TwineCompile - Cut C++Builder compile times by up to 50x!
Post Reply
NeOtaku
Posts: 3
Joined: Mon Dec 23, 2019 10:09 am

[C++ Builder 10.3.3] Color issues

Post by NeOtaku » Mon Dec 23, 2019 10:18 am

Hi everyone !

I'm encountering a strange issue since I've updated to C++ Builder 10.3.3... Je TwineCompile panel took some very hard to read colors. Here is an exemple :
twinecompile.png
(20.37 KiB) Not downloaded yet
I work with two computers and one is a laptop with a bad quality screen, I can't see anything :(

With 10.3.2, it was OK, the panel followed de Embarcadero theme (dark). But now, the bottom is white, and the text is too light.

Is there any solution ? I tried to change the colors in options, but it doesn't work :(

Thank you !

jomitech
Site Admin
Posts: 2013
Joined: Wed Oct 08, 2008 12:23 am

Re: [C++ Builder 10.3.3] Color issues

Post by jomitech » Mon Dec 23, 2019 6:36 pm

Please download the latest version of TwineCompile and re-install it. Update 3 did something weird with the theme colors and broke the UI.
Jon

NeOtaku
Posts: 3
Joined: Mon Dec 23, 2019 10:09 am

Re: [C++ Builder 10.3.3] Color issues

Post by NeOtaku » Fri Dec 27, 2019 7:31 am

It works ! From 5.0.0.126 to 5.0.0.140 : no more color issue :)
I didn't know there were an update, because I don't manage the account... I just get account ID from my IT, and now I will handle updates by myself.

Thank you for this incredible tool !

SOMNOmedics
Posts: 3
Joined: Thu Jan 02, 2020 4:56 am

Re: [C++ Builder 10.3.3] Color issues

Post by SOMNOmedics » Thu Jan 02, 2020 5:02 am

I have same problem, but i'm use C++ Builder 10.2.3 ( C++ Builder 10.3.3 deinstalliert)
I'm need fix (version 5.0.0.140) for C++ Builder 10.2.3.

Thanks
Last edited by SOMNOmedics on Fri Jan 03, 2020 6:54 am, edited 1 time in total.

jomitech
Site Admin
Posts: 2013
Joined: Wed Oct 08, 2008 12:23 am

Re: [C++ Builder 10.3.3] Color issues

Post by jomitech » Thu Jan 02, 2020 6:21 pm

I would suggest downloading the latest version and trying that - it may work with Update 2 as well.
Jon

SOMNOmedics
Posts: 3
Joined: Thu Jan 02, 2020 4:56 am

Re: [C++ Builder 10.3.3] Color issues

Post by SOMNOmedics » Fri Jan 03, 2020 6:35 am

Sorry.
Excuse me. I meant for version 10.2.3

jomitech
Site Admin
Posts: 2013
Joined: Wed Oct 08, 2008 12:23 am

Re: [C++ Builder 10.3.3] Color issues

Post by jomitech » Mon Jan 06, 2020 6:27 pm

Download the latest version of TwineCompile v5 (build 158). The color issues with Update 2 and 3 should be resolved correctly now.
Jon

SOMNOmedics
Posts: 3
Joined: Thu Jan 02, 2020 4:56 am

Re: [C++ Builder 10.3.3] Color issues

Post by SOMNOmedics » Tue Jan 07, 2020 2:30 am

It works !

Thanks

NeOtaku
Posts: 3
Joined: Mon Dec 23, 2019 10:09 am

Re: [C++ Builder 10.3.3] Color issues

Post by NeOtaku » Wed Feb 12, 2020 3:19 am

Hi there !

I just updated to 5.0.0.181 and the issue is back :( Except it's not gray, but black now (with dark theme, very hard to read).

I downgrade to .140, waiting the next version.

Good luck guys :)

jomitech
Site Admin
Posts: 2013
Joined: Wed Oct 08, 2008 12:23 am

Re: [C++ Builder 10.3.3] Color issues

Post by jomitech » Sat Feb 15, 2020 3:32 pm

The latest build (182) will solve this issue.
Jon

Post Reply